• noizfactory
  • SOuPevangelist
  • Email
  • Posts 579
  • Reputation 2
  • Member Since
  • Last Active
Email
  • Name Sachin Shrestha
  • Location: Mumbai
  • Occupation: Swiss Knife
  • Skype cgjunkie
  • Profile Picture
All Posts Topics Started Likes
SOuP 2017-05-14
Wow! Finally a whole new website and commercial license! This is great news Peter. Are there volume/site licensing options? I can mail you offline for details.

Cheers,
Sachin
0 0
SOuP 2017-01-15
Great updates Peter! I can't find the examples for collide in the new scenes archive...
0 0
Ziva Dynamics
Some really cool tech by the ex-Tissue folks:

0 0
Mixing PyMEL and Maya Python API
Yes, they are indeed wrapped CAPI objects. I was trying to find a shorthand to instantiate API objects by passing it the PyMEL objects' private api attributes but looks like I can't really mix the two.
0 0
CUDA 5 and CentOS/RHEL 7
Has anybody got this combination to work? CUDA 5 on RHEL 7? It doesn't seem to be officially supported but I need to maintain some legacy software so was wondering if anybody here has tried and got this combination working.

Thanks,
Sachin
0 0
Mixing PyMEL and Maya Python API
Is it possible to instantiate a Maya API object using PyMEL objects? For e.g. instantiating a MDagPath using a PyNode's __apimdagpath__() attribute?
0 0
myriadgrains
Trippy
0 0
vertexConstraint Update Bug
Did you release any updates yesterday? The last build is from 09_27 which I had already tried...
0 0
vertexConstraint Update Bug
Thanks, will try with today's release. Looks like its still getting uploaded.
0 0
vertexConstraint Update Bug
Hi Peter,

There seems to be a problem with vertexConstraint updates in viewport 2.0. I have attached a screen capture that illustrates this along-with the repro file.

If you scrub the timeline or change the frame when using Legacy VP then the node updates as expected - although even in Legacy VP there seems to be a visible delay but once the frame update finishes the constraint updates the position and orientation. However, in VP 2.0 the node does not seem to update correctly. The only way I could force an update is by turning the rotation channel on and off. Sometimes it seems that the update happens correctly if one of the locators is selected.

Let me know if you see the same at your end.

Maya 2016.5 + SOuP_2016_09_27
Maya 2015 + SOuP_2016_07_24
CentOS 6.4

Thanks,
Sachin
0 0
random color on meshes
Since you're using pfx, make sure that the vertex colors option is on when you convert the pfx to mesh. Pfx already provides color randomisation per tube so you can directly use that (and even see it in the viewport). The vertex colors are stored in a color set which you can access from the color set editor in the modeling menu. The colorSet1 is simply the default name of a new color set. You can change the name from the color set editor and provide the same name to userDataColor mode. You could add another colorSet on top of this which uses Peter's method and blend between 2 userDataColor nodes to get more variation at render time. During all of this make sure your export vertex colors option are turned ON on the pfx mesh shape node's Arnold section.
0 0
new release 2016-05-03
Yes, I see this on Maya 2016.5 Linux as well (CentOS 6.4).
0 0
new release 2016-05-03
Thanks for this build Peter. The previous one was giving some issues on certain linux machines (dlopen: cannot load any more object with static TLS) which seems to have been fixed now. Looks like it was gcc compile flags related. Have you switched to a newer gcc version since the last release?
0 0
pyExpression Broken and arrayExpresion Issue
Thanks Peter. I'll download the latest builds again and give it a shot.
0 0
pyExpression Broken and arrayExpresion Issue
Hi Peter,

Seems like the pyExpression node is still broken in the latest release. I get this error when trying to create the node:

# Warning: Unrecognized node type 'pyExpression'; preserving node information during this session. #
# Error: The destination attribute 'unknown1.time' cannot be found.
# Traceback (most recent call last):
#   File "", line 1, in
#   File "", line 13957, in create
# RuntimeError: The destination attribute 'unknown1.time' cannot be found. #

Also, in the arrayExpression node I'm trying to do this:

vector $sourceNormal = <<$EX, $EY, $EZ>>;
vector $sampleNormal = <<$EX2, $EY2, $EZ2>>;
float $dot = dot($sourceNormal, $sampleNormal);
$E = $dot

If I do arrayExpressionNode.getAttr('outArray') it gives me a vector array instead of a double array. Am I doing something wrong or is this broken?

Maya 2015 Extension 1 SP5, CentOS 6.4, SOuP_2016_04_20

Thanks,
0 0
count post selected

Add a Website Forum to your website.