moraff86
Hey guys,

I know I know, a nooby installation issue. I've searched the forums and it seems like I'm doing everything right yet it's still not working for me. Which sucks because I'm mega excited to start utilizing tension maps in my work. 

Anywho, so I've loaded the icons into user/maya/2016/prefs/ icons. I've loaded the .mel shelf into user/maya/2016/prefs/shelves. When I start up Maya I do indeed have the shelf auto-load with the three buttons (nodes, tools & connect). But for some reason when I browse to the .mll file with the plug-in manager it gives me this:

// Error: file: C:/Program Files/Autodesk/Maya2016/scripts/others/pluginWin.mel line 781: The specified module could not be found.
(SOuP) //

Is there something else I'm missing? The wiki seems pretty straightforward, it's only 3 steps after all. I'm really not code savvy so fire away if I'm just being dumb.
Quote 0 0
pshipkov
Try this in the script editor, mel tab:

loadPlugin "c:/path/to/SOuP.mll";

Does it work ?
Quote 0 0
moraff86
I got this.

// Error: line 1: Plug-in, "c:/path/to/SOuP.mll", was not found on MAYA_PLUG_IN_PATH. // 
Quote 0 0
pshipkov
You need to replace the path/to/ with the actual directory path where the SOuP.mll is located.
Notice that we are using "/" but not the windows "\".
Quote 0 0
moraff86

Still no luck. Different error at least.

// Error: line 1: Unable to dynamically load : c:/Program Files/Autodesk/Maya2016/bin/plug-ins/SOuP.mll
The specified module could not be found.
//
// Error: line 1: The specified module could not be found.
(SOuP) //



Quote 0 0
pshipkov
Hmm, that's strange.
So you can see the SOuP.mll plugin here:
c:/Program Files/Autodesk/Maya2016/bin/plug-ins/SOuP.mll
but when you type:
loadPlugin "c:/Program Files/Autodesk/Maya2016/bin/plug-ins/SOuP.mll" it does not work.

If that's the case - can you double check that you copied the right SOuP plugin that is for Maya2016, but not one of the 2016.5 or 2017 ?
Quote 1 0
moraff86
Ugh that's embarrassing. Guess I'm working too late. It's working now at least, major thanks pship. Really looking forward to using this stuff man.
Quote 0 0
pshipkov
No worries, i know how it feels.
Glad it turned out to be that simple at the end :)
Quote 0 0
Mathieu
Hi,

I have the exact same issue.

except: pass
# Error: Unable to dynamically load : C:/Program Files/Autodesk/Maya2016/bin/plug-ins/SOuP.mll
Le module spécifié est introuvable.
#
# Error: Le module spécifié est introuvable.
(SOuP) #

I am trying to run Soup on maya 2016 SP5

I also tried that mel command with no more succes :

loadPlugin "C:/Program Files/Autodesk/Maya2016/bin/plug-ins/SOuP.mll";

Any idea ?

Mathieu

Quote 0 0
pshipkov
Just to make it clear - i cancelled support for Maya2015 a while ago.
Wonder if you are trying to load plugins compiled for newer Maya versions to 2015 ?
Quote 0 0
Mathieu
Hi,

I was trying to run last release of soup on maya 2016 SP5. The problem was more about vc_redist.x86 and vc_redist.x64 2015 that were missing on my OS. With that update it works fine !

Thanks.


Quote 1 0
fitzfilmfx
I would also Like to report having the same problem in Maya 2016 SP6.

It sees the full path, but it will not load the plugin.

Quote 0 0
pshipkov
Check the message above from Mathieu.
Can you confirm this is not the problem you are facing ?
Quote 0 0
manusito
Hi pshipkov,

SouP is loading fine, but I am getting this error when trying to load BE_OpenVDB.mll on maya 2016 ext2 sp2 (2016.53). I made sure I copied the right file from the tar.gz to the maya/bin/plugins folder.

any clue? could it be because I don't have arnold loaded even if I am not going to use it?
Quote 0 0
besha1
If you not use arnold render Mtoa for Maya
You need to download Arnold SDK 4.2.16.0 http://www.solidangle.com/arnold/download/
and set path=Arnold SDK 4.2.16.0/bin or copy ai.dll in maya/bin
Quote 0 0

Add a Website Forum to your website.