Register Latest Topics
 
 
 


Reply
  Author   Comment   Page 1 of 2      1   2   Next
limeforce

Noodler
Registered:
Posts: 13
Reply with quote  #1 
Hey, has OpenVDB been built for Maya 2017 yet? Did not see it on the front page or here on the forums. Would be useful here :)
0
eddiegordo147

First taste
Registered:
Posts: 1
Reply with quote  #2 
+1

And thank you for your amazing work so far!
0
limeforce

Noodler
Registered:
Posts: 13
Reply with quote  #3 
Bump. Any news? Besha? :)

To be honest this is not very urgent or critical, but would be fun to be able to leverage VDBs in the latest & greatest Maya.

I assume it's the Arnold DLL doing all the heavy lifting in the SOuP OpenVDB release and the plugin just creates the nodes needed to access it so I guess I could write my own C++ plugin to do the same. Unfortunately I'm lacking the time/dedication to do that right now.

This is one of the things I'm toying with at the moment:
0
pshipkov

SOuP Jedi
Registered:
Posts: 4,641
Reply with quote  #4 
Can you explain some more about the video you posted ?
0
besha1

Wanting the recipes
Registered:
Posts: 77
Reply with quote  #5 
my version of openvdb has two packages
one for rendering in Arnold
second to work in mayа to create,change,recording,reading vdb format and so on

in the package for Arnold included
Shader aiBE_VDBArnoldRender
extensions BE_VDBArnoldRenderTranslator (the translator mayа node BE_VDBArnoldRender)
and my version of procedurals volume_openvdb

the package for maya included a lot of nodes and list them makes no sense
yes, the plug-in for maya BE_OpenVDB.mll
need ai.dll
just because I use some functions from the arnold api
for BE_VDBNoise,BE_VDBFlowNoise, BE_TurbulenceNoise,BE_AntiAliasedFlowNoise and BE_WorleyNoise.

for not patient
not final version
BE_OpenVDB for maya 2017 (tested in maya 2017 udate 1)
and for mtoa 1.3.1.1 all only for windows now

 
Attached Files
gz maya.tar.gz (2.64 MB, 287 views)
gz arnold.tar.gz (1.48 MB, 141 views)

0
limeforce

Noodler
Registered:
Posts: 13
Reply with quote  #6 
Peter: I'm using a school assignment (whole body sculpture) as a platform for tech experiments. The dream I'm chasing here is to be able to sculpt etc like ZBrush in Maya (which would bring added benefits like previewing final lighting with a GPU renderer without export-import hassle as well as leveraging Maya rigging & procedural & other tools).

The key technical thing here is very simple, given one has access to VDB in Maya: I wrote a tiny script that can remesh stuff using VDBFromPolygons-->ConvertVDB, resolution to remesh at is stored as an attribute on each mesh (shape). Makes it possible to work in a Dynamesh-like fashion using the Sculpt Tool brushes. Seems to be working pretty fine with 100-200k polys per mesh before it gets slow. It erodes the mesh over multiple iterations though. Oh, I guess the Youtube description is misleading, the script is not up on the public internet yet.

I was planning to do Part 2 tonight, but mysteriously BE_OpenVDB.mll refuses to load in 2016.5 and 2017 (pre & post Update 1) on my home machine so I'll have to go to sleep and continue at school. When I've spent a couple hours more on this project it should start looking much more like the end goal, a human character.
0
rachid

First taste
Registered:
Posts: 17
Reply with quote  #7 
Hi
The vdb file are not showing in viewport.the file loaded but nothing in viewport.
I can see it only when I heat render.
Also the flag "$F4.vdb" are not working.
Any solutions?
0
besha1

Wanting the recipes
Registered:
Posts: 77
Reply with quote  #8 
Quote:
Originally Posted by rachid
Hi The vdb file are not showing in viewport.the file loaded but nothing in viewport. I can see it only when I heat render. Also the flag "$F4.vdb" are not working. Any solutions?


in preferences change mode Viewport2.0 rendering engine opengl core profile to opengl
and check  Viewport->Show->Locators on.
0
rachid

First taste
Registered:
Posts: 17
Reply with quote  #9 
Thanks, I'll try thst once at home

Still the same problem
Nothing is showing in viewport, using Geforce 780 TI under win 8.1.
0
rachid

First taste
Registered:
Posts: 17
Reply with quote  #10 

Still the same problem
Nothing is showing in viewport, using Geforce 780 TI under win 8.1
0
besha1

Wanting the recipes
Registered:
Posts: 77
Reply with quote  #11 
Quote:
Originally Posted by rachid
Still the same problem Nothing is showing in viewport, using Geforce 780 TI under win 8.1

give me a scene
0
rachid

First taste
Registered:
Posts: 17
Reply with quote  #12 
Sorry
I can"t send the scene because it exceed the 2 mb that Soup allow
But any way here is the preview, I can render but can't see any thing.
Now I update for mtoa 1.4 and nothing work for vdb no vuewport no render.
Can you complile the vdb with the new API for mtoa 1.4?
Thanks

Attached Images
Click image for larger version - Name: tmp_16599-vdb_scene-761592450.jpg, Views: 106, Size: 649.60 KB 

0
pshipkov

SOuP Jedi
Registered:
Posts: 4,641
Reply with quote  #13 
You can email me a frame from the cache and the maya file.
0
rachid

First taste
Registered:
Posts: 17
Reply with quote  #14 
Here is the link
https://www.sendspace.com/file/rc3fgf
0
rachid

First taste
Registered:
Posts: 17
Reply with quote  #15 
Hi
Any news?
The cahe file are inside the maya project.
Thanks
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation: