pshipkov
Support for Maya2016.5.

OSX plugins for Maya2016 and 2016.5 are now identical with the Linux and Windows builds. Until now some tools, like mesh2arrays, interactive gpu caching system, etc., where missing.

Linux and OSX builds for Maya2016 and 2016.5 are now linking against libraries included in the Maya package, instead of standalone and/or static built ones. This should improve compatibility. The size of the compiled binaries is reduced.
Quote 0 0
mclausch
Hi Peter! Thanks for the update to support 2016.5!

Unfortunately I'm having a bit of trouble loading the plug-in on Linux. When I try I get this error:

// Error: file: ......./maya2016.5/scripts/others/pluginWin.mel line 767: ......./maya2016.5_3.16/dso/libgomp.so.1: version `GOMP_4.0' not found (required by ......./SOuP_2016_04_27/plug-ins/maya2016.5_linux/SOuP.so) (SOuP) //

Any ideas? libgomp.so.1 is present in the required location, but it only appears to define GOMP_1.0 GOMP_2.0, and GOMP_3.0, but not GOMP_4.0.

The new plug-ins do load fine on Linux for plain 2016. If that helps.

Thanks,
Matt

Quote 0 0
pshipkov
What Linux distro you use ?
Quote 0 0
djx
Same errors here... Centos 6.5 (Linux 2.6.32-431.29.2.el6.x86_64 x86_64)

/usr/lib64/libgomp.so.1: version `GOMP_4.0' not found (required by /library/rez/ext/maya_modules/soup/16.04.27/platform-linux/app_maya-beta_2016.2/bin/SOuP.so) //
// Error: line 1: /usr/lib64/libgomp.so.1: version `GOMP_4.0' not found (required by /library/rez/ext/maya_modules/soup/16.04.27/platform-linux/app_maya-beta_2016.2/bin/SOuP.so) (SOuP) //


Quote 0 0
pshipkov
Fixed it.
Download the updated archive.
Quote 0 0
djx
Thanks Peter. Loading fine now.

cheers
David

Quote 0 0
indrema
I've a problem on load SoUP on OS X:
Quote:

waitCursor -state on; $ignoreUpdateCallback = true; catch(`loadPlugin "/Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle"`); updatePluginUI( "9" ); $ignoreUpdateCallback = false; waitCursor -state off;
// Error: line 1: Unable to dynamically load : /Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle
dlopen(/Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle, 1): Library not loaded: /opt/local/lib/libgcc/libgomp.1.dylib
Referenced from: /Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle
Reason: image not found //
# Error: pymel : Failed to get controlCommand list from SOuP #
# Error: pymel : Failed to get modelEditorCommand list from SOuP #
# Error: pymel : Failed to get command list from SOuP #
# Error: pymel : Failed to get constraintCommand list from SOuP #
# Error: pymel.core : Failed to get depend nodes list from SOuP #
// Error: line 1: dlopen(/Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle, 1): Library not loaded: /opt/local/lib/libgcc/libgomp.1.dylib
Referenced from: /Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle
Reason: image not found (SOuP) //
updatePluginCallback()


Sorry for that
Quote 0 0
pshipkov

This looks like Maya2016.
What version of OSX you use ?

Quote 0 0
pshipkov
Will take a look tonight.
Quote 0 0
indrema
I'm on El Capitan.
Quote 0 0
shavale

Hi Peter,

Thanks for the updates. 

Facing issue to pipe below nodes in Linux [Centos 6.5] maya 2016.    
(pfxToarry : pointCloudToMesh : point : arrayToDynarray : instancer

Here I am passing pfx leaf position in to the point node to get random index id. Which works perfect in maya 2016 with windows system. But while it comes to the Linux system it says unable to get wightPP/positionPP out from the point node. Is this something to do with SOuP Linux compiled version?


I am attaching my setup file along with pipe image. (Built in maya 2016 win.) 

pfxToarray_id_Maya16_win.JPG

---
Sudarshan
Quote 0 0
pshipkov
Download and try again.
I linked agains the omp lib that comes with Maya. This should remove the need to install homebrew or macports omp libs.
Quote 0 0
indrema
Nope:
Quote: // Error: line 1: dlopen(/Users/indrema/Library/Preferences/Autodesk/maya/2016.5/plug-ins/SOuP.bundle, 1): Library not loaded: /opt/local/lib/libgcc/libgomp.1.dylib  Referenced from: /Users/indrema/Library/Preferences/Autodesk/maya/2016.5/plug-ins/SOuP.bundle  Reason: image not found (SOuP)
Quote: // Error: line 1: dlopen(/Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle, 1): Library not loaded: /opt/local/lib/libgcc/libgomp.1.dylib  Referenced from: /Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle  Reason: image not found (SOuP)
Quote 0 0
pshipkov
Ok, another build attached here.
Let me know.
Quote 0 0
indrema
Sorry:
Quote: // Error: line 1: dlopen(/Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle, 1): Symbol not found: __ZNSt8__detail12__prime_listE  Referenced from: /Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle  Expected in: /usr/lib/libstdc++.6.dylib in /Users/indrema/Library/Preferences/Autodesk/maya/2016/plug-ins/SOuP.bundle (SOuP)
Quote 0 0

Add a Website Forum to your website.