Register Latest Topics
 
 
 


Reply
  Author   Comment  
scorpes

Asking for seconds
Registered:
Posts: 21
Reply with quote  #1 
Hi, I'm trying to use the Morph node for my blendshapes and connect it to a displacement texture (so displacement changes with the morph target. But if I connect the target to an other node then the morph target breaks and doesn't work anymore in the viewport. Removing the connection and the morph target works again. It's connected like this:
connectAttr -f morph1.FULL_morphtarget layeredTexture.inputs[1].alpha;
0
pshipkov

SOuP Jedi
Registered:
Posts: 4,646
Reply with quote  #2 
Did you watch the video tutorial about Morph modifiers ?
I have the feeling that you are approaching this the wrong way.
The texture needs to be mapped to the points as "weights" and passed to the morph.targets[#].weightPP or .weightPP2.
There is UI that takes care of the most of the common cases.
Check the video tutorial and let me know if something is still unclear.
0
scorpes

Asking for seconds
Registered:
Posts: 21
Reply with quote  #3 
Hmm I think it's a different problem, after reopening the scene, the morph targets do not work anymore, maya now outputs this:
Target 0 will not be added to the cache. Target does not have corresponding control weight.
Target 1 will not be added to the cache. Target does not have corresponding control weight.
Target 2 will not be added to the cache. Target does not have corresponding control weight.
Target 3 will not be added to the cache. Target does not have corresponding control weight.
...

0
scorpes

Asking for seconds
Registered:
Posts: 21
Reply with quote  #4 
If I delete the current morph1 node and recreate it (compile) with the blendshape manager everything works again, save scene,  reopen scene and morph1 is broken and then ...
Target 0 will not be added to the cache. Target does not have corresponding control weight
........
....
...
.
0
scorpes

Asking for seconds
Registered:
Posts: 21
Reply with quote  #5 
I can provide you the scene but I can't send private messages to you.
I'm on Maya 2017 update 3 using linux and SOuP_2017_02_27_Maya2017.
0
pshipkov

SOuP Jedi
Registered:
Posts: 4,646
Reply with quote  #6 
Just attach a file here with a sphere and morph applied to it.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation: