holofermes
Hi.
I'm having some problems with the instancer properly working in batch mode.
Simple scene with the current setup

curve-->point-->arrayToDynamicArray-->instancer

i also have a displacyComponent attached to the point node, and all im passing through the dynamicArray is the point position. So when I open maya everytime the instances are not there, and if i render they dont show up, but as soon as i make any of the nodes in this stream dirty, the instances are drawn, and therefore render too. so I try to use a preRenderMel, which only worked while i run it from interface, while in batchmode it doesn't.
I would be great to know whats causing it, or if there is a quick hack-fix I can do in maya.


Quote 0 0
tomaya
I think that's similar to the problem I'm having to render the upres wavelet trough batch.
Quote 0 0
pshipkov
No this is a different issue. With the upresFluid node we have to cache the fluid and then remove the upreser if we are going to render in batch mode. I think it is caused by bug in Maya that refuses to refresh the fluid when in batch mode.

Few people reported refresh problems with the point node.
Can i please get a scene - this is the top "fix-it" item in my to-do list.

Thanks.

Quote 0 0
tomaya
Oh OK.
Thank you! I'll try that!

Quote 0 0
holofermes
here  is the scene.


Quote 0 0
pshipkov
I will have to take a closer look at the point node.
But there is a better node that will help you in your case - pointAttributeToArray.

curveShape->pointAttributeToArray.outPositionPP->arrayToDynArrays.inArray->instancer

Don't forget to turn-on the "point position" flag of the pointAttrToArray node so it outputs CV positions.

Quote 0 0
pshipkov
I resolved the point node's refresh issue at scene load time.
Tonight will push a new update.

Quote 0 0
holofermes
that sounds great!
I'm working with the pointAttributeToArray mixed with some arrayToArray, and attributeTransfer. this way i'm able to still keep the point node in there without breaking the procedurality, and also do batchrender, but it would be great if the point node would work while in batch without crazy trickery.

Quote 0 0