JeremyR
Ive been trying to export various motion graphic animations including mesh deformations using SOuPs solver for example, to .dae format but after importing it back into maya it doesnt preserve any animations only single frame. Ive tried baking to Alembic cache with the same results, .fbx format is the same. Ive tried adjusting the animation preset in the export file settings with no further success though. HAs anyone had any success with this? Ive read there is a bug using the .dae format but Im wondering if somebody has had success doing this?

I did get a warning saying .dae saves only transform data which kinda sucks for SOuP related animations, hence the reason why I saved it out as Alembic first. Also my method has been just to select the mesh in view and export, do I need to select any other nodes for this to work? Essentially I need just mesh data since the destination software wont understand SOuP nodes.

"2018-08-29 08:59:56: LOG: [WARNING] Reading or writing file. - While reading or writing a file the following notifications have been raised. Warning: 'Null' type not supported by COLLADA. Only the transform data of node: 'transform1' will be saved."
Quote 0 0
pshipkov
Collada is a pesky thing for sure.
Pass a scene and i can take a look.
Quote 0 0
JeremyR
Frames 1 - 120
.dae format

Thanks.
Quote 0 0
JeremyR
Did you have any luck?
Quote 0 0
pshipkov
I actually didn't have time to look at this one.
As you know, recently things have been rather busy 🙂
Quote 0 0
samadoni
i tried your scene and the extruded animation is working as expected if i export with alembic (2018.3)
Quote 0 0
JeremyR
Export as alembic
Import Alembic file
Export selection as .FBX_Dae
Default preset settings 
Exports frame 1 only

Tried changing some of the preset settings but nothing comes up with frame numbers or caches, I guess Im  missing something. (2018.1) Cant find  any Maya updates with the student version.
Quote 0 0
samadoni
just to be sure, when you export to alembic in the options the "cache time range" is not on current frame right? 
Quote 0 0
JeremyR
Yeah the cache is fine, animates after importing back into Maya.
I was more referring to export preset .dae settings.

Just updated to Maya2018.4 and still cant get animation out only current frame. Maybe my .dae settings are wrong though I think Ive tried everything under the sun.
Quote 0 0